PDA

View Full Version : Strani comportamenti del Flash-preload con l'audio


Galford
05-12-2002, 23:07
Ebbene: i preloading di Flash funzionano anche per un swf contenente solo una traccia audio ed il relativo bottone di stop?
Secondo Aethros no, ma secondo il sottoscritto sì, solo che quest'ultimo ha un problema :awk: :gha:

Alors, ho questo file.swf che contiene due scene: nella prima un preloading con barra percentuale del caricamento e nella seconda due layer di cui uno è la traccia audio e l'altro è quello con i bottoni di stop e ripresa del suono........ niente di anomalo insomma.

Metto online il tutto e vado al sito. STRANAMENTE, accade per caso una ed una sola di queste due situazioni:

1- il preload funziona correttamente, la barra si carica da 0 a 100 ed una volta raggiunto il massimo passa alla scena 2 e quindi parte l'audio. TUTTO OK

2- la barra del preloading parte da 0 e si ferma a circa il 60% ...bloccandosi inesorabilmente senza più andare avanti..

Sono sicuro che non sia un problema di connessione, dato che tutti gli altri siti vanno... che può essere?

E, domanda alternativa, QUALE e COME si fa un preloading semplicissimo, ma chiaro e funzionante al 100%?

Grassie a chi risponderà :)

Moebius
06-12-2002, 21:13
che versione di flash usi?

Galford
07-12-2002, 17:29
per ora la 5, ma l'Mx sta attendendo da due mesi che io formatti ^^... in ogni caso il problema, ho ricontrollato, pare si verifichi solo quando accedo con Inwind :gha: connessione pacco..... per tutto il resto funzions :)