PDA

View Full Version : [Driver] Ati Radeon


Moses
18-05-2004, 21:19
Esistono i driver per le radeon oltre ai pacchetti RPM?

Grazie in anticipatamente

<-3=-YoShi-=3->
19-05-2004, 00:11
In che senso?

Se intendi i sorgenti, esistono solo quelli DRM nel kernel (2.6) oppure su http://dri.sourceforge.net/cgi-bin/moin.cgi/ trovi quelli per le serie 2.4

Dei driver ufficiali, invece ci sono solo gli rpm forniti da ati

P.S. Che driver usi adesso?

Moses
19-05-2004, 00:47
forse ho trovato...

con la slack dovrebbero funzionare gli rpm facendo

rpm2targz nome_file.rpm

installpkg nome_file.tar.gz

speriamo bene :D

Moses
19-05-2004, 12:13
cambiando discorso.... qualcuno ha mai trovato problemi ad installarli? (prevenire meglio che curare :D)

<-3=-YoShi-=3->
19-05-2004, 19:00
Con la slack nn so, cmq gli unici accorgimenti (se usi i driver ufficiali) sono
abilitare l'agpgart come modulo nel kernel, disattivare il DRM, Attivare l'rtc e il MTRR nel kernel.
Poi skippare l'opengl su xfree, installare i driver, caricare i moduli agpgart e fglrx, reskippare opengl su ati e lanciare il programma
/opt/ati/bin/./fglrxconfig

<-3=-YoShi-=3->
19-05-2004, 19:04
P.S. se vuoi dare un occhio qua (http://www.gentoo.it/tips/ATI-Driver.html) c' una guida (un po di spam opensource a me stesso) su come installare i driver ati.

E' per gentoo, cmq nn credo che slack sia tanto diversa.

P.P.S E' un po vecchiotta (mi sembra -> devo vedere, che sia ancora per i 3.2.8 che andavano compilati) ma la puoi adattare ai 3.7. adesso appena ho un minuto la ri-aggiorno.

Edit: Che Pi**a ho schiacciato reply anzich edit...e ho fatto 2 post...Hai mod. se volete potete mergiarmeli in un unico post

Moses
20-05-2004, 00:32
mmmm ecco cosa mi spara fuori quando lancio un qualsiasi gioco (per esempio ut2004)

Couldn't set video mode: Couldn't find matching GLX visual


History:

Exiting due to error

la cosa strana che mi dice che in esecuzione ho le GLX Mesa e non quelle della Ati :scratch:

bah vediamo se la notte mi porta consiglio

p.s. non ho Xfree.... ho Xorg

<-3=-YoShi-=3->
20-05-2004, 18:19
Originally posted by Moses
mmmm ecco cosa mi spara fuori quando lancio un qualsiasi gioco (per esempio ut2004)

Couldn't set video mode: Couldn't find matching GLX visual


History:

Exiting due to error


mmm...ma se dai da X cosa dicono? riesci a postarlo?

$ fglrxinfo
e
$ glxinfo


Originally posted by Moses
la cosa strana che mi dice che in esecuzione ho le GLX Mesa e non quelle della Ati :scratch:


dovrebbero darti una roba cos

bash-2.05b$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9200 DDR Generic
OpenGL version string: 1.3 (X4.3.0-3.7.6)

----------------------------------------

bash-2.05b$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes <-----------Questa riga a te da Yes o No?
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9200 DDR Generic
OpenGL version string: 1.3 (X4.3.0-3.7.6)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_ATI_element_array,
GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader, GL_ATI_map_object_buffer,
GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
GL_ATI_vertex_array_object, GL_ATI_vertex_attrib_array_object,
GL_ATI_vertex_streams, GL_ATIX_texture_env_combine3,
GL_ATIX_texture_env_route, GL_ATIX_vertex_shader_output_point_size,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_stencil_wrap, GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
GL_EXT_vertex_array, GL_EXT_vertex_shader, GL_HP_occlusion_test,
GL_NV_texgen_reflection, GL_NV_blend_square, GL_NV_occlusion_query,
GL_SGI_color_matrix, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_border_clamp, GL_SGIS_texture_lod,
GL_SGIS_generate_mipmap, GL_SGIS_multitexture, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess


Originally posted by Moses
bah vediamo se la notte mi porta consiglio

p.s. non ho Xfree.... ho Xorg

Nn credo cambi molto, il codice di Xorg + o - quello di xfree 4.4...

P.S. Nn che stai usando il Radeon FB? prova a dare un occhio nel kernel...xch pu dare problemi, Io uso il vga classico e funge da dio lo stesso.


EDIT: ---> Mi venuto in mente solo adesso, in XF86Config-4 hai load GLX?

Moses
21-05-2004, 14:39
scusami ma ho parecchie cosette da finire... appena riesco posto tutto...

cmq non ho proprio XF86Config-4.... ho xorg.conf :D e ho messo load "glx"

Moses
28-05-2004, 12:35
moses@Alpha:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)

moses@Alpha:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_SGI_make_current_read, GLX_SGIS_multisample
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_visual_select_group
GLX extensions:
GLX_ARB_get_proc_address, GLX_EXT_import_context, GLX_EXT_visual_info,
GLX_EXT_visual_rating
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_shadow, GL_ARB_shadow_ambient,
GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_func_separate, GL_EXT_blend_logic_op, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint, GL_EXT_copy_texture,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, GL_EXT_stencil_wrap,
GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
GL_EXT_vertex_array, GL_APPLE_packed_pixels, GL_ATI_texture_mirror_once,
GL_ATI_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square,
GL_NV_point_sprite, GL_NV_texgen_reflection, GL_NV_texture_rectangle,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
GL_SGIX_shadow, GL_SGIX_shadow_ambient
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None

<-3=-YoShi-=3->
28-05-2004, 20:21
Originally posted by Moses
direct rendering: No
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)


Sono queste 2 righe che sono sbagliate...

I moduli (agpgart, chipset_della_tua_scheda_madre-agp e fglrx) vengono caricati?

dai un occhio nei sorgenti del kernel se hai messo il DRM attivato.
Se si Disattivalo, ricompila e rebootta col kernel rifatto.

Se tutto ok, prova a fare cos

# opengl-update xfree
# reinstalla i driver ati
# opengl-update ati


Dovrebbe andare. Al max ricopia la sezione device che c' nella guida qui (http://www.gentoo.it/tips/ATI-Driver.html) (in questi giorni la faccio riuppare aggiornata) nel tuo conf di xorg.


P.S. Come ti trovi con Xorg? pi stabile di Xfree?

Moses
29-05-2004, 12:01
si con Xorg mi trovo benone....

prover a controllare qualcosina...

Moses
03-07-2004, 15:34
K ora sembra tutto andare.... tranne che me la vede come una radeon 8500 prototipo invece che una radeon 9200 :gha:

controllo delle cosine e vediamo ^^