PDA

View Full Version : [Linux] Alcune domande....


Erik Vindkaldr
10-05-2004, 20:28
Sono alle prime armi con Linux (da una vita), avrei qualche domanda da fare. So benissimo che se mi metto a cercare trovo di sicuro faq, manuali, etc con le risposte, però non ho al momento proprio il tempo materiale per dedicare qualche minuto a cose diverse dagli impegni quotidiani, quindi chiedo qui sperando in qualche anima pia...
:look:


- Ho una lan di 4 pc con il server della lan che usa Win98. Vorrei riuscire a condividere la connessione internet anche quando uso Linux.

- [Cosa molto strana e buffa ai limiti del comico] Il mouse è "posseduto". Quando sono in madalità testuale, se muovo il mouse, senza che io faccia nulla (senza clickare), il mouse seleziona TUTTO lungo le righe in cui lo muovo e quello che seleziona lo manda come comando O_O"
Ho istallato di recente la RedHat9, in precedenza ho usato sempre la RH da di altre versioni e non ho mai avuto problemi di questo tipo °_°"

<-3=-YoShi-=3->
10-05-2004, 23:51
Originally posted by Erik Vindkaldr

- Ho una lan di 4 pc con il server della lan che usa Win98. Vorrei riuscire a condividere la connessione internet anche quando uso Linux.


Ma il server (quello col 98) è anche quello che ha installato linux? se si basta impostare l'ip del pc linux nella casellina Gateway degli altri pc e dovrebbe funzionare, se vuoi condividere anche i file con linuz devi installare Samba (ti consiglio la 3.0)

Originally posted by Erik Vindkaldr
- [Cosa molto strana e buffa ai limiti del comico] Il mouse è "posseduto". Quando sono in madalità testuale, se muovo il mouse, senza che io faccia nulla (senza clickare), il mouse seleziona TUTTO lungo le righe in cui lo muovo e quello che seleziona lo manda come comando O_O"
Ho istallato di recente la RedHat9, in precedenza ho usato sempre la RH da di altre versioni e non ho mai avuto problemi di questo tipo °_°" [/B]

Ma da console virtuale ALT+F1,F2 ecc.. oppure da Console sotto modalità grafica?

Una cosa molto strana...che tipo di mouse è? usb, ps/2...
Red Hat nn la conosco, ma potresti provare a dare un occhio nel kernel,
/usr/src/linux/make menuconfig e vedere se in
Device Driver -> Input Device Support -> c'è il supporto x il tuo mouse in console.

Moses
11-05-2004, 12:15
Originally posted by <-3=-YoShi-=3->
Ma il server (quello col 98) è anche quello che ha installato linux? se si basta impostare l'ip del pc linux nella casellina Gateway degli altri pc e dovrebbe funzionare

Non penso... :)

dai questi comandi

# echo 1 > /proc/sys/net/ipv4/ip_forward

# /sbin/iptables -t nat -A POSTROUTING -s Range_Ip_tua_rete -o ppp0 -j MASQUERADE

(Range_ip_tua_rete for example 192.168.0.0/24)

buona fortuna :)

<-3=-YoShi-=3->
11-05-2004, 18:39
C'ero quasi dai... :) mi son dimenticato l'ip fowarding :) :forgot:

Erik Vindkaldr
11-05-2004, 20:54
Ma il server (quello col 98) è anche quello che ha installato linux?
No, il pc server (con il 98) non sono io.



Ho provato i due comandi
# echo 1 > /proc/sys/net/ipv4/ip_forward
# /sbin/iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o ppp0 -j MASQUERADE

Vedo il gruppo della lan, i file condivisi degli altri tre pc, però la connessione internet no...


Ah avverto che prima di postare avevo provato a fare delle prove :look: cambiando il Dns Primary sulle configurazioni Network, però, prima di provare quei due comandi, l'ho rimesso vuoto come prima :look:






Ma da console virtuale ALT+F1,F2 ecc.. oppure da Console sotto modalità grafica?

Una cosa molto strana...che tipo di mouse è? usb, ps/2...
Red Hat nn la conosco, ma potresti provare a dare un occhio nel kernel,
/usr/src/linux/make menuconfig e vedere se in
Device Driver -> Input Device Support -> c'è il supporto x il tuo mouse in console.
Modalità testuale... Mouse ps/2
Non saprei come fare a guardare nel kernel...
La cartella /usr/src contiene solo cartelle vuote
Cmq il mouse è istallato come Generic Wheel Mouse Ps/2





- Come si leva Checking for new hardware al boot?

Moses
12-05-2004, 01:33
Ma su linux la connessione a internet ti funziona???

se fai ifconfig ti compare ppp0?

Erik Vindkaldr
12-05-2004, 12:31
Mi compare.... :look:
eth0
Link encap:Ethernet HWaddr 00:10:A7:1A:DC:69
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:2914 (2.8 Kb) TX bytes:342 (342.0 b)
Interrupt:10 Base address:0xc000

lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2677 errors:0 dropped:0 overruns:0 frame:0
TX packets:2677 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:182366 (178.0 Kb) TX bytes:182366 (178.0 Kb)

Jerry Lee
13-05-2004, 12:30
io ho RH9 e con il mouse non ho problemi


per il resto non so aiutarti, sono un neofita pure io....

Erik Vindkaldr
13-05-2004, 13:54
Mi hanno detto che non è proprio possibile fare quello che serve a me (condividere la connessione internet in una lan con server che usa Win98) perchè sul server serve una versione di windows che "sappia instradare i pacchetti" tipo win2000 o winxp-pro o win2003. Win98 non va bene :(

Moses
14-05-2004, 10:58
Non ho capito allora... vuoi usare linux per condividere o win98??

nel primo caso devi creare la connessione su linux (non so quale tipo di connessione hai), dare i comandi che ti ho detto e mettere nei client l'ip della macchina linux nel gateway...

nel secondo caso non è vero che non è possibile... ci sono molti programmini che permettono di condividere la connessione con win98 (wingate è uno dei tanti mi pare :scratch: )

<-3=-YoShi-=3->
15-05-2004, 00:05
Originally posted by Erik Vindkaldr
Non saprei come fare a guardare nel kernel...
La cartella /usr/src contiene solo cartelle vuote
Cmq il mouse è istallato come Generic Wheel Mouse Ps/2


Probabilmente nn hai installato il pacchetto con i sorgenti del kernel.


Originally posted by Erik Vindkaldr
- Come si leva Checking for new hardware al boot? [/B]
Nn so se si possa levare (nn ho red hat) devi provare a guardare nei demoni che partono all'avvio.

Per la rete, come è fatta? da quanto ho capito c'è un hub che collega i computer (di cui uno linux) e il server (col modem attaccato) che ha win98.giusto?

Moses
15-05-2004, 10:08
in redhat di solito è possibile eliminare demoni al boot attraverso l'utility linuxconf...

Conan III
15-05-2004, 23:44
in etc/inetd.conf c sono tutti i demoni ke si avviano, prova a mettere un # al nome del processo

Erik Vindkaldr
27-05-2004, 21:17
Alla fine avevo risolto
Grazie a tutti :bow:

Per il "Checking for new hardware" ho trovato in rete come disabilitarlo
chkconfig kudzu off

Per la connessione, mi son accorto che non esisteva il dhcp o_O me lo son fatto passare e una volta istallato finalmente potevo condividere la connessione della lan

Il mouse ho fatto delle prove, ho provato a configurarlo come generic mouse 2 button (ps/2) anzichè generic wheel mouse (ps/2) e almeno non mi rompeva più come prima....