PDA

View Full Version : problem scheda audio


Moses
23-10-2003, 23:46
Allora prima che sfondo il computer spero che qualcuno mi illumini su questo problema :D

Allora ho installato la slack 9.1 (kernel 2.4.22) tutto bene solo che il mio comp è un biproc e devo ricompilare il kernelozzo per mettere il supporto smp.... già che ci sono tolgo tutta la merda che non mi serve (esempio supporto isdn ecc... ecc..)

ricompilo e va tutto a posto tranne una cosa che prima della compilazione funzionava benissimo e cioè la schedozza audio normalissima (SB 16)

il modulo è caricato (anche pechè nelle impostazioni del kernel la parte sound non l'ho toccata)

provo a lanciare il comando alsaconf e mi dice che non rileva nessuna scheda audio :(

adesso..... perchè cavolo non deve funzionare???? :scratch:

illuminatemi please prima che risolvo il problema a badilate :D

Azathoth[Andaria]
24-10-2003, 07:46
la parte sound nn l'hai toccata?
quindi nn hai scelto i moduli per alsa?

Moses
24-10-2003, 08:31
la parte sound non l'ho toccata perchè funzionava alla grande e i moduli alsa erano già caricati :)

Azathoth[Andaria]
24-10-2003, 08:34
hai dato un occhiata a quello che fanno gli script?

Moses
25-10-2003, 10:02
Allora vediamo un pò cosa combina sta merda di PC

appena installata la slack 9.1 il computer canta balla e suona images/advsmilies/cool/11.gif (alsa rulez) ma non ha il supporto per il mio biproc

ricompilo e tocco solo il smp e imposto la tipologia di processore

riavvio e magicamente vedo il mio biproc MA!!!! ecco cosa dice quando carica il modulo della scheda audio:


/lib/modules/2.4.22/kernel/sound/pci/snd-ens1371.o: init_module: No such device
/lib/modules/2.4.22/kernel/sound/pci/snd-ens1371.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22/kernel/sound/pci/snd-ens1371.o: insmod /lib/modules/2.4.22/kernel/sound/pci/snd-ens1371.o failed
/lib/modules/2.4.22/kernel/sound/pci/snd-ens1371.o: insmod snd-ens1371 failed

invece il dmesg dice:

Ensoniq AudioPCI soundcard not found or device busy


adesso...... tutto ciò non ha senso ma mi sforzerò a credere che sbaglio qualcosa..... qualcuno può aiutarmi??? :D

Grassie :D

Moses
25-10-2003, 15:49
Se può servire allego il file della configurazione del kernel :)

logicamente non è per nulla ottimizzato perchè è solo per fare una prova :D

Moses
25-10-2003, 16:47
Grazie di tutto ma alla fine la mia testaccia dura ha avuto la meglio sulla macchina :D

ora Alsa è perfettamente Funzionante :D

chiudo :)