PDA

View Full Version : Sostituzione Kernel


Astrid
13-10-2003, 21:20
Ho il kernel della RH9 [2.4] che mi fa i capricci per il modem e la conexant stata cos gentile da mettere i driver a pagamento;
volevo montare il kernel della RH 7.3 x ovviare al problema ma quando installo mi dice: E' installata una versione pi aggiornata del kernel e non posso continuare,come risolvo?
Fatemi sapere,grazie :)

Nagash
13-10-2003, 22:15
Cio scusami, tu metti un kernel pi vecchio per risolvere il problema? Mah, mi puzza abbastanza. I conextant cmq sono winmodem quasi tutti, bisogna ritoccare lo script del modem, ma assolutamente non mi ricordo come si fa :D

Astrid
13-10-2003, 22:33
No xk con la 7.3 + driver andava benissimo,ora li ha messi a 15$ :(

Pardo
14-10-2003, 17:42
PREMESSO che non ho MAI usato RPM per cambiare kernel

quindi NON SO cosa possa succedere, ed e` altamente probabile che qualcosa di negativo succedera`, la possibilita` di nn mandare tutto a troie dipende dalla tua conoscenza del sistema..

per fare " L'aggiornamento " (siamo alla frutta cmq..) , devi aggiungere '--force' al comando

Cmq se il kernel ke vuoi mettere e` un 2.2 conviene lasciar perdere
Nn funzionera` mai nn facendolo con rpm almeno.
C saranno altri milioni di programmi installati ke richiedono funzionalita` del 2.4

vabbe cmq il driver a pagamento mi sembra ridicolo magari informati meglio nn ha alcun senso e poi c sono milioni di persone che hanno quei modem del cazzo vabbe che sono tutti windowsiani ma qualcuno che lo usa con GNU/Linux c'e`

DM Ilweran
17-10-2003, 16:21
Pardo... e' estremamente raro che una applicazione in userspace usi delle funzionalita' del kernel (e per fortuna... sai che casino ad esempio passando a 2.6 ?)
+++
Comunque, assicurati che effettivamente pagare i driver sia l'unica soluzione, il che mi sembra stranissimo, dato che se hai l'hardware devi averlo per forza pagato, quindi in linea teorica dovresti avere il pieno diritto di usarlo...
Cmq, cambiar kernel non e' sicuramente la soluzione, e RH 7.3 e' dell'anno scorso, quindi 2.4